`
xinjiang
  • 浏览: 54531 次
  • 性别: Icon_minigender_1
  • 来自: 北京
社区版块
存档分类
最新评论

POJ 1577--Falling Leaves

Go 
阅读更多

题目来源:http://poj.org/problem?id=1577

Description:


Figure 1

Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem .
A binary tree of letters may be one of two things:
  1. It may be empty.
  2. It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters:
  1. Empty trees are omitted completely.
  2. Each node is indicated by
    • Its letter data,
    • A line segment down to the left to the left subtree, if the left subtree is nonempty,
    • A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y.

The preorder traversal of a tree of letters satisfies the defining properties:
  1. If the tree is empty, then the preorder traversal is empty.
  2. If the tree is not empty, then the preorder traversal consists of the following, in order
    • The data from the root node,
    • The preorder traversal of the root's left subtree,
    • The preorder traversal of the root's right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY.

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies:

The root's data comes later in the alphabet than all the data in the nodes in the left subtree.

The root's data comes earlier in the alphabet than all the data in the nodes in the right subtree.
The problem:

Consider the following sequence of operations on a binary search tree of letters Remove the leaves and list the data removed Repeat this procedure until the tree is empty Starting from the tree below on the left,  we produce the sequence of trees shown, and then the empty tree

by removing the leaves with data BDHPY CM GQ K Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.

Input:

The input file will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters. The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk ('*'). The last data set is followed by a line containing only a dollar sign ('$'). There are no blanks or empty lines in the input.

Output:

For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

Example Input:

BDHPY 
CM 
GQ 
K 
* 
AC 
B 
$

Example Output:

KGCBDHQMPY
BAC

此题就是就是建立一颗有序二叉树,在进行前序遍历即可得到结果。对于第一组数据KGQCMBDHPY建立一颗有序二叉树,
过程如下:

#include <stdio.h>
#include <string.h>
#include <malloc.h>

typedef struct BiTree
{
    /*自定义二叉树*/
    char ch;
    struct BiTree *lchild;
    struct BiTree *rchild;
}BiTree;


BiTree *createBiTree(char ch)
{
    /*创建一个叶子节点*/
    BiTree *leaf = (BiTree *)malloc(sizeof(BiTree));
    leaf->ch = ch;
    leaf->lchild = NULL;
    leaf->rchild = NULL;
    return leaf;
}


BiTree *insertBiTree(BiTree *root, char ch)
{
    BiTree *leaf = root;

    if(root == NULL)
    {
        root = createBiTree(ch);
        return root;
    }

    while(leaf)
    {
        if((leaf->ch) > ch)
        {
            if(leaf->lchild == NULL)  //如果ch比该节点小且该节点的左子树为空
            {                         //就将ch放在该节点的左子树上
                leaf->lchild = createBiTree(ch);
                break;
            }
            else                     //否则继续遍历直到找到合适的位置位置
            {
                leaf = leaf->lchild;
            }
        }
        else  if((leaf->ch) < ch)
        {
            if(leaf->rchild == NULL)  //如果ch比该节点大且该节点的右子树为空
            {                         //就将ch放在该节点的右子树上
                leaf->rchild = createBiTree(ch);
                break;
            }
            else                      //否则继续遍历直到找到合适的位置位置
            {
                leaf = leaf->rchild;
            }
        }
    }

    return root;
}

void preOrderTraver(BiTree *root)
{
    /*前序遍历二叉树,并且输出结果*/
    BiTree *p, *stack[100];
    int top = 0;

    p = root;
    while(!(p == NULL && top == 0))
    {
        while(p != NULL)
        {
            stack[top] = p;   //将当前指针压入栈中
            top++;
            printf("%c", p->ch);
            p = p->lchild;
        }

        if(top <= 0)  return;   //栈空时结束
        else
        {
            top--;
            p = stack[top];
            p = p->rchild;
        }
    }

}

int main()
{
    char str[50], p[10000];
    int length;
    int i;
    BiTree *root = NULL;


    while(1)
    {
        scanf("%s", str);
        if(strcmp(str, "*") == 0 || strcmp(str, "$") == 0)
        {
            length = strlen(p);
            for(i = length-1; i >= 0; i--)
            {
               root = insertBiTree(root, p[i]);
            }
            preOrderTraver(root);
            printf("\n");
            if(strcmp(str, "$") == 0)  break;
            root = NULL;
            memset(p, '\0', sizeof(p));

        }
        else
        {
            strcat(p, str);
        }
    }

    return 0;
}
 

 

  • 大小: 57 KB
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics